Wednesday, March 29, 2017

Take a few minutes to patch Oracle APEX 5.1

Yesterday a first patch set of Oracle Application Express (APEX) 5.1 has been made available to download.

one-of patches

If you encounter issues, you can ask for support and most likely a bit later a patch is made available through support.oracle.com. The APEX team is doing a great job with this.

For example some people using APEX Office Print had an issue which was caused by a bug in APEX_JSON (which we heavily use behind the scenes). The next day the APEX Dev Team already made a patch available (PSE 25650850).

patch set

Instead of applying those one-off patches, you can wait for a patch set which includes those one-off patches and more. If you didn't move to Oracle APEX 5.1 yet, you can just download the latest version which includes 5.1.1 immediately. 

There're many fixes for the Interactive Grid features, but next to that, many others as well, like for example login issues.

applying the patch set

If you're on Oracle APEX 5.1, search for patch 25341386. Unzip the file, stop the webserver, run @apxpatch, copy the images folder and start the webserver again.
About 2 minutes later you're on the latest version. 


Happy patching...

1 comment:

Akshay said...

Hi Dimitri Gielis,

We are using apex 5.1 (Which is on C drive). Now we want upgrade it to 5.1.1. I have downloaded the patch and unzipped it somewhere on E drive.
I did following steps to upgrade
1. download patch
2. unzipped it somewhere on E drive
3. open cmd go to location of patch(E drive location)
4. login to sql
5. run command @apxpatch.sql;

After this i am getting following error

apxpatch_con.sql
SQL> @apxpatch.sql;
BEGIN dbms_registry.check_server_instance; END;

*
ERROR at line 1:
ORA-39702: database not open for UPGRADE or DOWNGRADE
ORA-06512: at "SYS.DBMS_REGISTRY", line 934
ORA-06512: at line 1

Can you help on this?

Regards
Akshay